玩蛇网提供最新Python编程技术信息以及Python资源下载!

只有python2.6o可以在sx版本mod_wsgi中使用吗?

osx版本的mod_wsgi是不是只支持到python2.6,我用的是python2.7,现在用pythonbrew切换到2.6.3,但是apache报错

modwsgi (pid=4149): Target WSGI script '/www//index.py' cannot be loaded as Python module. modwsgi (pid=4149): Exception occurred processing WSGI script '/www//index.py'. ImportError: No module named tornado.web

显然是支持的,切换到任何版本的 python 都需要安装对应的 wsgi,建议你使用 virtualenv 来避免这种问题。

你的报错内容是 No module named tornado.web,也就是说这个 package 没有安装。tornado 可能装在了 python 2.7 的目录里,所以 2.6.3 下自然就报错了

玩蛇网文章,转载请注明出处和文章网址:https://www.iplaypy.com/wenda/wd20130.html

相关文章 Recommend

玩蛇网Python互助QQ群,欢迎加入-->: 106381465 玩蛇网Python新手群
修订日期:2017年05月24日 - 14时22分54秒 发布自玩蛇网

您现在的位置: 玩蛇网首页 > Python问题解答 > 正文内容
我要分享到:

必知PYTHON教程 Must Know PYTHON Tutorials

必知PYTHON模块 Must Know PYTHON Modules