玩蛇网提供最新Python编程技术信息以及Python资源下载!

Python pip安装需要再下载一次pip吗

我的pip的版本

    pip -V
    pip 1.5.4 from /usr/local/lib/python2.7/site-packages (python 2.7)

然后我执行安装

pip install python-cinderclient>=1.0.1
Downloading/unpacking python-cinderclient>=1.0.1 
    File was already downloaded /home/pipdownload/python-cinderclient-1.0.8.tar.gz
  Running setup.py (path:/tmp/pip_build_root/python-cinderclient/setup.py) egg_info for package python-cinderclient
    install_dir .
    Installed /tmp/pip_build_root/python-cinderclient/pbr-0.7.0-py2.7.egg
    Searching for pip>=1.4
    Reading http://pypi.python.org/simple/pip/
    Best match: pip 1.5.4
    Downloading https://pypi.python.org/packages/source/p/pip/pip-1.5.4.tar.gz#md5=834b2904f92d46aaa333267fb1c922bb
    Processing pip-1.5.4.tar.gz
    Running pip-1.5.4/setup.py -q bdist_egg --dist-dir /tmp/easy_install-oJ7xLW/pip-1.5.4/egg-dist-tmp-sZPgAc

我的问题是 pip已经是1.5.4了为什么还会出现

Best match: pip 1.5.4
Downloading https://pypi.python.org/packages/source/p/pip/pip-1.5.4.tar.gz

如何解决这个问题,修改源代码?

玩蛇网文章,转载请注明出处和文章网址:https://www.iplaypy.com/wenda/wd19774.html

相关文章 Recommend

玩蛇网Python互助QQ群,欢迎加入-->: 106381465 玩蛇网Python新手群
修订日期:2017年03月30日 - 11时20分57秒 发布自玩蛇网

您现在的位置: 玩蛇网首页 > Python问题解答 > 正文内容
我要分享到:

必知PYTHON教程 Must Know PYTHON Tutorials

必知PYTHON模块 Must Know PYTHON Modules