玩蛇网提供最新Python编程技术信息以及Python资源下载!

在python中用pip install matplotlib安装却失败啦

错误提示:

Command /usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip_build_root/matplotlib/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-ModyBS-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /tmp/pip_build_root/matplotlib
Traceback (most recent call last):
  File "/usr/bin/pip", line 11, in <module>
    sys.exit(main())
  File "/usr/local/python27/lib/python2.7/site-packages/pip/__init__.py", line 185, in main
    return command.main(cmd_args)
  File "/usr/local/python27/lib/python2.7/site-packages/pip/basecommand.py", line 161, in main
    text = '\n'.join(complete_log)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 105: ordinal not in range(128)

如果看的话,有图:

已找到问题。本题可删。


应要求,说一下解决过程。

刚开始当然是各种蛋疼各种分析错误各种搜索。。。

然后猛然发现几个月前在装某个东西的时候,由于需要 Python2.7 ,于是就替换了系统默认的 python 2.6, 但 yum 目前还不支持 2.7,于是,就让 yum 自个儿用 2.6

问题就在这里。安装的时候调用的是 2.6 的 python,而编译运行调用的是 2.7,总之理不清他们到底什么情况下被调用,乱成一锅粥。

索性,卸了 python 2.7,修改默认的为 2.6,具体操作就不一一写了。从此编译安装神马的都没问题了。

玩蛇网文章,转载请注明出处和文章网址:https://www.iplaypy.com/wenda/wd19634.html

相关文章 Recommend

玩蛇网Python互助QQ群,欢迎加入-->: 106381465 玩蛇网Python新手群
修订日期:2017年05月22日 - 09时08分50秒 发布自玩蛇网

您现在的位置: 玩蛇网首页 > Python问题解答 > 正文内容
我要分享到:

必知PYTHON教程 Must Know PYTHON Tutorials

必知PYTHON模块 Must Know PYTHON Modules