玩蛇网提供最新Python编程技术信息以及Python资源下载!

Python Pycurl7.19.7安装出错如何解决

安装完毕之后import pycurl出现如下错误:

pycurl: libcurl link-time version (7.19.7) is older than compile-time version (7.37.1)

是因为我curl版本太新了么?pycurl最新版本就是7.19.7,如何解决?

—————————@update—————————

libcurl的问题已解决。只需把pycurl.egg依赖的libcurl.so.4链接到7.37.1版本的libcurl即可。随即又出现以下问题:

ImportError: pycurl: libcurl link-time ssl backend (openssl) is different from compile-time ssl backend (none/other)

在官网安装文档里查询到,需使用

python setup.py --with-[ssl|gnutls|nss] install

重新安装后发现libcurl.so.4软链接被重置,所以会报第一种错误。手动修改链接链接libcurl之后又会报第二种错误。

也就是说,我现在要么遇到libcurl版本不一致的错误,要么就是ssl版本不一致。

How to solve it?

这个更通用一点,mac下还需要Root 权限:

# pip uninstall pycurl
# export PYCURL_SSL_LIBRARY=nss
# pip install pycurl

虽然我不是用pip安装的,但是重新用pip安装就好了= =.

http://stackoverflow.com/questions/21096436/pip-install-pycurl-ssl-backend-error

玩蛇网文章,转载请注明出处和文章网址:https://www.iplaypy.com/wenda/wd19473.html

相关文章 Recommend

玩蛇网Python互助QQ群,欢迎加入-->: 106381465 玩蛇网Python新手群
修订日期:2017年05月23日 - 16时48分46秒 发布自玩蛇网

您现在的位置: 玩蛇网首页 > Python问题解答 > 正文内容
我要分享到:

必知PYTHON教程 Must Know PYTHON Tutorials

必知PYTHON模块 Must Know PYTHON Modules