玩蛇网提供最新Python编程技术信息以及Python资源下载!

有哪位大神知道Yosemite DP7 pip install mysql-python失败原因

Yosemite DP7 下使用:pip install mysql-python失败。
错误信息如下:

同楼上,编译需要xcode的编译工具链支持

贴图又更新了……就不能贴文本么……非要贴个图片上来…………

显然你是在用OSX10.10+Xcode6.0的组合,要知道Xcode6.0里面是木有10.10SDK的。
去网上下载一个Xcode 6.1 Beta吧,那里面有10.10SDK。


你要先装Xcode
如果你从Xcode5升级到了Xcode6,那有可能你的xcode-tool路径还是老的,你可以看看xcode-select -p的输出是不是之前Xcode5下的目录,如果是这样你需要更新一下,用命令:
sudo xcode-select -s /Applications/Xcode-Beta.app/Contents/Developer
这里的/Applications/Xcode-Beta.app/Contents/Developer是你的Xcode6安装目录,确认是否正确。
如果上述都没问题,再用sudo xcode-select --install命令确认命令行工具都装了。

嗯?你问题里的贴图更新了?现在的错误是“CrushReporterSupport”找不到了?这东西是你装了没有?

玩蛇网文章,转载请注明出处和文章网址:https://www.iplaypy.com/wenda/wd19412.html

相关文章 Recommend

玩蛇网Python互助QQ群,欢迎加入-->: 106381465 玩蛇网Python新手群
修订日期:2017年05月24日 - 17时38分23秒 发布自玩蛇网

您现在的位置: 玩蛇网首页 > Python问题解答 > 正文内容
我要分享到:

必知PYTHON教程 Must Know PYTHON Tutorials

必知PYTHON模块 Must Know PYTHON Modules