玩蛇网提供最新Python编程技术信息以及Python资源下载!

Python应用部署到SAE上报错,无法找到flask.ext.admin是何原因

如图。无法找到flask.ext.admin。。。但是我已经将flask_admin打包上传
代码如下

这是项目文件的结构

sae上的代码文件结构图

更新:问题已经解决
原因是SAE上的Flask版本太旧。。。需要将新版的Flask,和Flask-sqlalchemy打包上传,同时Flask-admin却不能用最新版本(1.1.0),用这个版本会出现找不到某些包的错误。。我用的1.0.3就可以正常运行了。。

运行下面的命令看看flask是否成功导入了

import flask as f
print f.__file__

如果成功导入 说明flask没问题 可能是你ext.admin里有些依赖包没打包进去

玩蛇网文章,转载请注明出处和文章网址:https://www.iplaypy.com/wenda/wd18963.html

相关文章 Recommend

玩蛇网Python互助QQ群,欢迎加入-->: 106381465 玩蛇网Python新手群
修订日期:2017年05月19日 - 13时09分16秒 发布自玩蛇网

您现在的位置: 玩蛇网首页 > Python问题解答 > 正文内容
我要分享到:

必知PYTHON教程 Must Know PYTHON Tutorials

必知PYTHON模块 Must Know PYTHON Modules