玩蛇网提供最新Python编程技术信息以及Python资源下载!

Python tornado Linux系统平台, 是实现了Epoll模型, 还是会使用Linux的Epoll ?

实际现象

  • 想弄清楚tornado的Epoll

预期现象

上下文环境

  • 产品版本: Tornado最新

  • 操作系统: Linux

  • Python 2.7.x

可以去看tornadoioloop模块。里面有说明

...
class IOLoop(Configurable):
    """A level-triggered I/O loop.
    We use `epoll` (Linux) or `kqueue` (BSD and Mac OS X) if they
    are available, or else we fall back on select(). If you are
    implementing a system that needs to handle thousands of
    simultaneous connections, you should use a system that supports
    either `epoll` or `kqueue`.
...

Linux系统中用epoll,BSDMac OS Xkqueue,其他系统中用select

使用的是python标准库中的select模块。实际上select模块也只是对系统的select的调用,并没有自己实现。

想深入研究的话可以看源码


感谢 @依云 的补充。
python标准库中的select模块是对系统各种I/O复用方案的封装。

>>> import platform
>>> platform.linux_distribution()
('Red Hat Enterprise Linux Server', '6.5', 'Santiago')
>>> import select
>>> dir(select)
['EPOLLERR', 'EPOLLET', 'EPOLLHUP', 'EPOLLIN', 'EPOLLMSG', 'EPOLLONESHOT', 'EPOLLOUT',         
'EPOLLPRI', 'EPOLLRDBAND', 'EPOLLRDNORM', 'EPOLLWRBAND', 'EPOLLWRNORM', 'PIPE_BUF', 
'POLLERR', 'POLLHUP', 'POLLIN', 'POLLMSG', 'POLLNVAL', 'POLLOUT', 'POLLPRI', 'POLLRDBAND', 
'POLLRDNORM', 'POLLWRBAND', 'POLLWRNORM', '__doc__', '__file__', '__name__', 
'__package__', 'epoll', 'error', 'poll', 'select']

玩蛇网文章,转载请注明出处和文章网址:https://www.iplaypy.com/wenda/wd13868.html

相关文章 Recommend

玩蛇网Python互助QQ群,欢迎加入-->: 106381465 玩蛇网Python新手群
修订日期:2017年05月22日 - 09时00分07秒 发布自玩蛇网

您现在的位置: 玩蛇网首页 > Python问题解答 > 正文内容
我要分享到:

必知PYTHON教程 Must Know PYTHON Tutorials

必知PYTHON模块 Must Know PYTHON Modules