玩蛇网提供最新Python编程技术信息以及Python资源下载!
您现在的位置: 玩蛇网首页 > Python问题解答 > 正文内容

virtualenv创建项目可以指定python版本号吗?如何指定

CentOS 系统默认安装的版本的 python 2.5 的。我又编译安装了个 2.7 的。在 2.5 的版本里 pip install 了 virtualenv。

现在,我要用 virtualenv 创建一个虚拟环境,想指定虚拟环境 python 的版本为 2.7,如何搞定?

virtualenv -p

使用 virtualenv -p ~/pyenv/python3.5 env3.5 来指定创建一个3.5的env

用法:

$ virtualenv [OPTIONS] DEST_DIR

选项:

-p PYTHON_EXE, --python=PYTHON_EXE
指定所用的python解析器的版本,比如 --python=python2.5 就使用2.5版本的解析器创建新的隔离环境。         默认使用的是当前系统安装(/usr/bin/python)的python解析器

为什么不用pyenv 控制多个版本的python呢?

你可以用 pythonbrew 来做 python 的版本控制,然后用 pythonbrew 选择 python 版本进而创建该版本下的 virtualenv

virtualenv TEST --python=python2.7

http://virtualenv-chinese-docs.readthedocs.org/en/latest/#id29

玩蛇网文章,转载请注明出处和文章网址:http://www.iplaypy.com/wenda/wd19080.html

相关文章 Recommend

玩蛇网Python互助QQ群,欢迎加入-->: 106381465 玩蛇网Python新手群
修订日期:2017年06月01日 - 16时58分29秒 发布自玩蛇网

我要分享到:

必知PYTHON教程 Must Know PYTHON Tutorials

必知PYTHON模块 Must Know PYTHON Modules